Todo funcionando a la primera en Ubuntu 8.04 para Acer Aspire 5720

Acabo de instalar Ubuntu 8.04 Hardy Heron en el Acer Aspire 5720 y he podido comprobar que absolutamente todo ha funcionado a la primera: la webcam, la tarjeta de sonido, la tarjeta wireless, la aceleracion 3D, compiz fusion… Todo sin necesidad de recompilar el kernel o instalar modulos externos como en la versión anterior.

Parece ser que ya no va a hacer falta que publique ninguna solución de aquí en adelante jeje.

23 Responses to “Todo funcionando a la primera en Ubuntu 8.04 para Acer Aspire 5720”

  1. Titiritero dice:

    Nos vas a dejar sin tus lecciones. Es increíble. Es lo que suele hacer un típico ingrato.

  2. Alfredo dice:

    No te preocupes acabo de encontrar algo que no funciona, pero todavia no se como arreglarlo, a lo mejor ni siquiera se puede.

  3. Titiritero dice:

    jajaja, Mi aprendiz te puede pasar un tutorial para que lo pongas aquí de como se las ingenio para que le funcionará su inalambrica que en el ubuntu 8.04 no había manera.

  4. Alfredo dice:

    Vale, dile que me lo pase

  5. Pancho Lopez dice:

    Hola Alfredo:

    Yo he instalado el ubuntu 8.04 en una acer aspire 5720-4216 y todo va menos el inalambrico. ¿tienes alguna idea de por donde ira el problema?
    Gracias

  6. Alfredo dice:

    a que te refieres con 5720-4216? el que yo tengo es simplemente 5720 y la inalambrica funcionaba directamente.

  7. gonzo dice:

    al parecer asi es muchos bugs se han corregido desde la version anterior del ubuntu, o sea de 7.10 gutsy gibbon a la 8.04.
    tengo una Acer Aspire 5520-3691 y con la version 7.10 despues de instalar no tenia sonido la tarjeta nvidia no funcionaba y la webcam que trae integrada la laptop no funcionaba tampoco, asi que tenia que activar el el sonido con el linux-backports, la nvidia geforce 7000m fue para mi un dolor de cabeza (aclaro soy un poco novato en linux), tuve que desistalar los nvidia que traia como driver restringido, entrar a consola detener las x instalar driver descargado de la pagina, arrancar las x de nuevo o reiniciar para la inalambrica use el ndiswrapper, en estos momentos solo me falta checar si funciona mi tarjeta inalambrica, el video esta aceptable con los drivers restringidos, anteriormente al arrancar salia el logo de nvidia pero eso no tiene importancia si esta funcionando la aceleracion grafica jejeje, me he llavado la grata sorpresa que al terminar la instalacion limpia del 8.04 al arrancar ya tenia sonido, la webcam ya funciona con el amsn y no tuve que compilar el nucleo y la aceleradora grafica se detectaba pero al entrar a controladores restringidos aparecia la nvidia pero que no estaba activada o algo asi, funciono al conectar la red alambrica y hacer una actualizacion (apt-get update).
    cada dia va quedando mejor el ubuntu a mi en lo particular esta mucho mejor que el windows vista, de hecho el vista casi nunca lo uso prefiero el xp de mi compu de escritorio pero en la laptop uso el ubuntu jejejeje.

    aprovecho para enviarte un saludo afectuoso desde el sureste (yucatan) de mexico.

  8. Alfredo dice:

    gonzo:
    Otro saludo afectuoso desde el norte de Europa (Noruega), gracias por comentar.

  9. Titiritero dice:

    Un saludo desde el sureste de la península ibérica (Murcia, Lorca o Balsikak).

  10. Omar dice:

    Hola Alfredo, tengo exactamente el mismo equipo que el tuyo e instale la misma version de Ubuntu que utilizas, pero, a mi la tarjeta Wireless no me funciona. Que puede estar ocurriendo?

    Saludos.

  11. gonzo dice:

    pues les vuelvo a comentar ahora desde mi laptop (acer aspire 5520-3691; turion 2.2 ghz, nvidia 7000m, 120 gb disco duro, quemador de dvd, lector de tarjetas, webcam, originalmente 1 gb de ram actualmente 2.5gb ram) con la tarjeta inalámbrica funcionando.
    pues el driver restringido que trajo el sistema (ubuntu 8.04 LTS) no funciono o puede ser que no le haya encontrado como; así que use el ndiswrapper. Les voy a tratar de decir brevemente (jejeje) que pasos seguí para hacerla funcionar.
    1) remover driver restringido: sudo rmmod ath_pci
    2) ponerlo en la lista negra: sudo gedit /etc/modprobe.d/blacklist, añadir al final del archivo blacklist ath_pci, cerrar y guardar cambios.
    3) reiniciar el sistema.
    4) instalar ndiswrapper, yo lo hice desde el synaptic también se puede bajar de la web oficial, en la web de ndiswrapper te dan el enlace para bajar el driver de la tarjeta de red inalámbrica. para ver la información de la tarjeta usen lspci -n la mía es 168c:001c.
    5) cargar el driver: sudo ndiswrapper -i net5211.inf (yo ejecute el comando dentro del directorio que contenía el “driver” no se si se puede hacer desde raíz).
    6) instalar: sudo ndiswrapper -m
    7) hacer que cargue el modulo en el arranque para no tener que hacerlo manualmente cada vez que quiera usar la inalámbrica: sudo gedit /etc/modules y añadir al final la siguiente linea, ndiswrapper.

    por lo menos en mi caso particular eso tuve que hacer para poder usar mi tarjeta de red inalámbrica.
    espero que le sea útil a los que tengan un problema parecido al mio, y esperemos que la próxima versión ya corra estas tarjetas inalámbricas “nativamente” jajajaja
    les envió un saludo afectuoso a todos los que lean este blog.

  12. Alfredo dice:

    Omar: No se por que te puede estar fallando, podrian ser mil cosas. mira a ver si tienes el modulo ejecutandose para la wireless. Has probado a darle al boton?

    gonzo: Gracias por comentar, otro saludo afectuoso para ti.

  13. Titiritero dice:

    Yo, también, yo también (culico veo culico quiero), un saludo afectuoso para todos todos.

  14. Omar dice:

    Si Alfredo, le he dado al boton, pero en el gestor de configuracion de red no aparece la opcion de red inalambrica, solo aparece la conexion cableada y la conexion punto a punto.

  15. Alfredo dice:

    Vale vale, era solo por asegurarme. Mira a ver que es lo que pasa si haces un sudo modprobe iwl3945
    y dimelo

  16. Albert dice:

    Tengo dos sistemas operativos en mi ACER TravelMate 5720: WINDOWS VISTA (WV) AND UBUNTU 8.04. Con WV no tengo ningún problema, pero con ubuntu no me reconoce ninguna conexión wireless. En España (estoy en el extranjero por estudios) utilicé conexión vía módem por cable y no tuve ningún problema.

    Por último, el botón de activar el wireless no me funciona en ubuntu. A continuación dos reportes del Terminal: 1. lspci, 2. sudo lshw -C networky 3. iwconfig:

    albert@albert-laptop:~$ lspci
    00:00.0 Host bridge: Intel Corporation Mobile PM965/GM965/GL960 Memory Controller Hub (rev 03) 00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03) 00:02.1 Display controller: Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (rev 03) 00:1a.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #4 (rev 03) 00:1a.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #5 (rev 03) 00:1a.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #2 (rev 03) 00:1b.0 Audio device: Intel Corporation 82801H (ICH8 Family) HD Audio Controller (rev 03) 00:1c.0 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 1 (rev 03) 00:1c.1 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 2 (rev 03) 00:1c.2 PCI bridge: Intel Corporation 82801H (ICH8 Family) PCI Express Port 3 (rev 03) 00:1d.0 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #1 (rev 03) 00:1d.1 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #2 (rev 03) 00:1d.2 USB Controller: Intel Corporation 82801H (ICH8 Family) USB UHCI Controller #3 (rev 03) 00:1d.7 USB Controller: Intel Corporation 82801H (ICH8 Family) USB2 EHCI Controller #1 (rev 03) 00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3) 00:1f.0 ISA bridge: Intel Corporation 82801HEM (ICH8M) LPC Interface Controller (rev 03) 00:1f.1 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) IDE Controller (rev 03) 00:1f.2 IDE interface: Intel Corporation 82801HBM/HEM (ICH8M/ICH8M-E) SATA IDE Controller (rev 03) 00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03) 02:00.0 Ethernet controller: Broadcom Corporation NetLink BCM5787M Gigabit Ethernet PCI Express (rev 02) 04:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02) 0f:06.0 CardBus bridge: Texas Instruments PCIxx12 Cardbus Controller 0f:06.1 FireWire (IEEE 1394): Texas Instruments PCIxx12 OHCI Compliant IEEE 1394 Host Controller 0f:06.2 Mass storage controller: Texas Instruments 5-in-1 Multimedia Card Reader (SD/MMC/MS/MS PRO/xD) 0f:06.3 SD Host controller: Texas Instruments PCIxx12 SDA Standard Compliant SD Host Controller albert@albert-laptop:~$

    albert@albert-laptop:~$ sudo lshw -C network [sudo] password for albert: *-network description: Ethernet interface product: NetLink BCM5787M Gigabit Ethernet PCI Express vendor: Broadcom Corporation physical id: 0 bus info: pci@0000:02:00.0 logical name: eth0 version: 02 serial: 00:1d:72:32:90:be capacity: 1GB/s width: 64 bits clock: 33MHz capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.86 firmware=5787m-v3.23 latency=0 link=no module=tg3 multicast=yes port=twisted pair *-network description: Wireless interface product: PRO/Wireless 3945ABG Network Connection vendor: Intel Corporation physical id: 0 bus info: pci@0000:04:00.0 logical name: wmaster0 version: 02 serial: 00:1f:3c:2f:61:04 width: 32 bits clock: 33MHz capabilities: pm msi pciexpress bus_master cap_list logical ethernet physical wireless configuration: broadcast=yes driver=iwl3945 latency=0 module=iwl3945 multicast=yes wireless=IEEE 802.11g albert@albert-laptop:~$ iwconfig lo no wireless extensions. eth0 no wireless extensions. irda0 no wireless extensions. wmaster0 no wireless extensions. wlan0 IEEE 802.11g ESSID:”” Nickname:”” Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated Tx-Power=27 dBm Retry min limit:7 RTS thr:off Fragment thr=2346 B Power Management:off Link Quality:0 Signal level:0 Noise level:0 Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0 Tx excessive retries:0 Invalid misc:0 Missed beacon:0
    albert@albert-laptop:~$

  17. Titiritero dice:

    ¡Ingrato! pero contestale al pobre Albert que está esperando una respuesta aunque solo sea un hola.

  18. Alfredo dice:

    Pues la verdad es que ahora mismo no te se localizar el fallo.

  19. Albert dice:

    [B]Hola de nuevo:

    Aporto más reportes por si me podéis ayudar. He probado los siguientes comandos:[/B]

    sudo iwconfig wlan0 essid any
    sudo dhclient wlan0
    sudo ifconfig wlan0 up

    Y estoss son los reportes:

    albert@albert-laptop:~$ sudo iwconfig wlan0 essid any
    [sudo] password for albert:

    albert@albert-laptop:~$ sudo dhclient wlan0
    Internet Systems Consortium DHCP Client V3.0.6
    Copyright 2004-2007 Internet Systems Consortium.
    All rights reserved.
    For info, please visit http://www.isc.org/sw/dhcp/

    wmaster0: unknown hardware address type 801
    wmaster0: unknown hardware address type 801
    Listening on LPF/wlan0/00:1f:3c:2f:61:04
    Sending on LPF/wlan0/00:1f:3c:2f:61:04
    Sending on Socket/fallback
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 6
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 9
    DHCPDISCOVER on wlan0 to 255.255.255.255 port 67 interval 16
    receive_packet failed on wlan0: Network is down
    No DHCPOFFERS received.
    No working leases in persistent database – sleeping.

    albert@albert-laptop:~$ sudo ifconfig wlan0 up
    SIOCSIFFLAGS: Error de entrada/salida
    albert@albert-laptop:~$

  20. Alfredo dice:

    Yo no controlo mucho de redes inalambricas, tal vez deberías preguntarle a Titiritero.

  21. Titiritero dice:

    No, yo no se nada de redes inalámbricas.

    Alfredo piensa más en lo que escribes. Es la primera vez en esta entrada que entras al trapo conmigo sin solucionar el problema de otros. Se que estas de vacaciones pero…

  22. Vegaxus dice:

    Hola, yo tengo el mismo portátil pero tengo problemas con las teclas especiales del Aspire 5720, me refiero a las teclas FN y las de dollar y EuroSign que no se como hacerlo funcionar. Saludos

  23. Alfredo dice:

    Que versión de Ubuntu estás instalando?

Leave a Reply


+ 1 = 8